Discogs - Load times may be slower than usual – Incident details

All systems operational

Load times may be slower than usual

Resolved
Degraded performance
Started 4 days agoLasted about 3 hours

Affected

Website

Degraded performance from 1:00 PM to 4:12 PM

Discography

Degraded performance from 1:00 PM to 4:12 PM

Release pages

Degraded performance from 1:00 PM to 4:12 PM

Master Release pages

Degraded performance from 1:00 PM to 4:12 PM

Artist pages

Degraded performance from 1:00 PM to 4:12 PM

Label pages

Degraded performance from 1:00 PM to 4:12 PM

Updates
  • Resolved
    Resolved

    Service is restored and everything is working again in perfect harmony! Thank you for your patience.

  • Investigating
    Investigating

    Part of the site may be slow to load, including database pages, release statistics, and the Wantlist and Collection tools.

    Our team is investigating the issue and working as swiftly as possible to find a solution. Thank you for your patience!