Discogs - Incident affecting Login – Incident details
Report an issue
Report an issue
Dark mode
All systems operational
Incident affecting Login
Resolved
Operational
Started 3 months ago
Lasted about 1 hour
Affected
Website
Login
Updates
Resolved
September 26, 2024 at 5:30 PM
Resolved
September 26, 2024 at 5:30 PM
This incident has been resolved.
Investigating
September 26, 2024 at 4:39 PM
Investigating
September 26, 2024 at 4:39 PM
We are currently investigating this incident.